why not a,b or x,y?
why not a,b or x,y?
why not a,b or x,y?
When I’m doing coding interviews I always like to start off and say I’m a big fan of very long variable names. “As descriptive as you can be” I say. Then I get to my first for loop. Instead of i I use “iterator” and then when I start a nested loop I use “jiterator” and it always gets a laugh.
I used to conduct coding interviews at my old job. If someone came in and had some humor like that, it would be big bonus points in my book. Being someone I would like to be on a team with is very important. Plus, I think it shows confidence and being comfortable in situations that make most people nervous.
I've been at two start ups and they had me interview people. Honestly this is what I looked for. I'd ask basic questions to prove you had an idea about coding, but I can teach someone to code, I can't teach someone to be someone I like working with.
And even if it didn’t help my chances directly like that, even getting a small chuckle would help me be more comfortable and confident.
Honestly finding someone who can relax and intergrate into your team culture is arguably more important that anything
i is for index. j is simply the next letter and we're too lazy to think up something meaningful
jndex
kndex
I always thought it stood for iterator
I sometimes use it for "item", knowing full well its established meaning as index or iterator, because I'm a rebel.
i2?
ii
This is the real answer
It depends. x
and y
are either elements or coordinates, a
and b
usually elements though in e.g. Haskell reserved (by convention) for type variables.
The i
j
k
l
series is reserved for indices. n
m
etc. are the counts of something, as such you'll see i
counting up to n
. Both are due to mathematical sum notation and general mathematical convention. Random google result:
Let x1, x2, x3, …xn denote a set of n numbers. x1 is the first number in the set. xi represents the ith number in the set.
...if you're using a language in which you use i
often chances are you should stop coding in C and get yourself a language with iterators. Manual loops are a bug magnet.
It's a shame iterators in JS are trash for memory if you have a giant array
A useful tip I picked up was to use ii
instead of j
for an inner loop. It's far more distinct than j
.
If for some terrible reason you have even more inner loops you can easily continue the trend i
, ii
, iii
, iiii
, iiiii
- or iv
, v
if you're feeling roman
If you have the need to nest 5 levels of for-loops, I suggest taking a step back and rethinking your approach, my friend.
Even if that other approach is just refactoring it into separate methods.
I just do i2, i3, etc
Becomes unreadable if you're using the iter values a lot
Two or three "i"s is readable, but any more and you're counting.
I'Ve started using i, k, m, n that's usually enough.
At this point we might as well go full Roman as you suggested. MXMCIIV to MXMCCVII as indices.
When you have multiple indices you're also bound to have multiple cardinals those indices count up to, say foo.length
and bar.length
, so foo_i
and bar_i
are perfectly legible and self-documenting. A bit Hungarian but Hungarian is good in small amounts. Unless you're dealing with width
and height
in which case it's x
and y
but it's not that width_i
would be incomprehensible.
x is used for map, filter, etc. a and b are used for sorts, comparisons and merges. y might be used if I'm doing multiple lambda expressions (but that means I'm in a bad place already). I have no idea why, but these are firm rules in my brain.
I've gotten used to using the singular form as in...
records.filter((record) => ...)
Not saying this way is better but it works for me.
I do this too. I hate using just x
, because it's so non-descriptive.
Yes! I love using x (and xs) for functions over whatever the thing is (or things are).
People who name iterators with one letter have no soul.
two letters it is then
And people who iterate over 3D space using firstDimensionIndex, secondDimensionIndex, and thirdDimensionIndex instead of x, y, z have no sense 😜
x, y, and z are absolutely fine for spatial addressing.
It's my understanding that i,j are conventionally used in mathematics which carried over into programming, but specifically it comes from Fortran in which all integer variables start with "I" through "N" based on said mathematical convention
Yep, this is the answer. In Fortran, all variables are assumed to be floats, unless the variable starts with I, J, K, L, M or N. I’m sure they had a good reason, but it sounds so bizarre today!
In fact this goes all the way back to Hamilton when he invented quaternion, in which i,j,k are used as basis vectors (which are generalizations of the imaginary i). Later Gibbs dropped the scalar component and gave us the modern vector.
In old FORTAN variable starting with I...N are integers. This is how the practice began.
Learned that VERY recently from here, at NDC Oslo 2023, he mentioned it around 42:54. The whole talk is worth watching, its about the history of javascript all the way back to FORTRAN (the talk itself starts at 25:03).
Oh wow, I thought it was because "i" was a short way of writing "index". Then "j" was just logical after that.
You are still correct! The letters I & n are the first letters on Index.
I generally use a for each type loop or a map because I am usually applying some function across a collection, and in both cases I use the singular name from the collections plural.
’Cities.map(city -> …)’
For (val city in cities)
If I actually need the index for some reason I still prefer loop structures that give me the index and the item together
*note syntax pulled out of my head and not necessarily belonging to any specific language.
For ( city, index in cities)
cities.map((city, index) -> … )
If I need to double loop a matrix array I would use rowIndex and ColIndex for the indexes.
I always thought i for index when iterating through an array. Then you can't use i again in a nested loop so j follows.
Tho sometimes x, y if the array represents coordinates.
Only a maniac would use a, b.
One of the very first lines of code I ever wrote was:
10 FOR a = 1 TO 70
In Spectrum Basic. I do tend to use I these days, I’ve calmed down since my childhood days 😀
I find it hard to read when these are together:
From all the possible character combinations, somehow the lookalike combinations are among the most popular. Yes, probably comes from math. I hated it even more when my math prof's i and j on the board were indistinguishable.
It's a thin J, okay kid? Git gud, get on my level.
When the practice started, most (if not all) programming languages used capital letters. IIRC the computers that ran early FORTRAN (which is where the I,J,K, etc. convention comes from) didn't even support lower case letters.
I prefer index variable names that are two words. The second word is always 'index' and the first word describes the enumerable objects. carIndex, productIndex, thingIndex
I'm not paid by the character count. Longer and more descriptive is better. Long lines that go past your 1080p monitor are probably not long because of variable names but because you insist on doing many things in one line (quit doin' that). For small functions this isn't necessary, but too often I'm shunted to the middle of a big function with two or three indecies doing acrobatics over one another and while working on it I have to constantly remind myself that this i and j mean particular things.
I have had too many times where I have been confused trying to figure out a giant nested loop because the writer used i/j/k or x/y/z. It’s even worse when they confused when a particular bug is because they confused what their single letter variables were and used j somewhere instead of i and no one caught it because it is so easy to brush over. Name your stuff what it is, make your life easier, make others lives easier.
If you need three iterators, it's time for at least one function encapsulating that inner loop.
If you use I,j,k.. what do you do if you need another? I hate seeing lowercase l as a var.
If i is lowercase too then it doesn't make a difference
But tbh if your function is having mit than 3 levels of nested loops you should probably rethink that function
... or you just work in 3D ....
This is the answer my college professors would have said. Lol
I like range-based for loops. You can just name the iterator after the object that it actually is. Have to be a little careful though, if the container is named a plural noun, and the natural name is the same word minus the easy-to-miss 's'.
a plural noun
undefined
sheep.each do |sheep| sheep.baaah end
Oh shit :D
This is one of the few things I really like about JS/TS. for (thing of things) is very legible and self documenting.
for <thing> in <amount> do...
I think it's a convention taken from math notation conventions.
I is short for "index" for a traditional for loop for mapping over an array and looking up by index. J comes after I and is used for nested loops so it doesn't shadow the outer I.
Is it for “index” or “iterator”?
I used starcraft references in mine till the project lead demanded I knock it off.
The protoss quotes were perfect.
If I ever have to write some kind of huge load balancer, I'll do my best to call it "The Queen removed of the Universe".
Int index = 0 But you shorten the name to Int I = 0
I always use x or y, coming from Python background
OMG the PRNDL
I don't like i and j since they are commonly used for imaginary numbers. I like to start on n. Probably because I do DSP.
I dunno why, but I have always used x, y, z for my generic for-loop variables.
I started using the first letter of the thing I am iterating over. This is particularly helpful with nested loops so I can easily remember which index variable corresponds to which thing.
don't mind i
but personally always use index
or x, y, z
for games
chuckles in Python
When my brain doesn’t work I’ll resort to naming them the single of the plural. Like keys turns into key when i don’t wanna call it “objkey” or “outrageouslylongnamethatmayormaynotbeafittongwordtodescribeakey”
I thought it come from mathematical sequences, but actually it doesn't. My best bet is that i
is the shorthand for index
Well. I guess I'm then a some kind of heretic then. 🤷
I'm honestly prefer short but (usually) complete words. Somewhere along the line I realized that being explicit really helps when you need to change it later.
due to convention everybody understands what i and j are, I don't think they need longer names. If it's something more complicated than a counter or index then maybe you should be using a foreach loop instead (if language supports it)
I generally use 'count' for a counter and 'idx' for index.
I'm not using C or Java languages though - if I were I would probably go with the more classic terse approach.
Also, if I'm reviewing a PR and I have to load more of the diff context to understand what a variable represents, then that variable has the wrong name.
WTF, I have never used nor seen "j."
I don't usually have to name these variables these days though. Pretty much everything I use has foreach or some functional programming type stuff.
And like that, the off-by-one mistakes disappear.
j
is for a loop in a loop.
It was very common in text books when showing nested loops
undefined
int nWhatTheCount = 0; for (int i = 0; i < 10; i++) { for (int j = 0; j < i; j++) { for (int k = 0; k < j; k++) { for (int l = 0; l < k; l++) { // and on, and on nWhatTheCount++; } } } }
foreach is useful when you don't need to know the index of something. If you do, conventional i, j, k, etc. are useful.
A lot of it depends what you're doing (number crunching, for instance) or if you're in a limited programming language (why won't BASIC die already?) where parallel arrays are still a thing.